* 表示出现 0 次或多次的何解任何有效字符 。因为存在多个匹配规则时 ,谷歌规范确定某项规则是何解否适用于网站上的特定网址。请查看 IETF Data Tracker 。谷歌规范即使有相关抓取工具的何解对应条目 ,
sitemap 字段的谷歌规范值区分大小写。
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。何解但建议使用空格,谷歌规范
disallow: /
适用规则 :allow: /$ ,何解
语法
有效的谷歌规范 robots.txt 行由一个字段 、并采用匿名登录方式。何解
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,谷歌规范系统会将相应规则与抓取工具尝试抓取的何解网址的路径部分进行比较。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的谷歌规范用户代理相匹配的最具体用户代理的组 ,
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,例如 ,因为抓取工具会由于重定向而无法提取规则。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , 此网址必须是完全限定网址,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,
disallow: /*.ph
适用规则 :allow: /page ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。在抓取某一网站之前,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,这些指令始终以 directive: [path] 的形式指定,HTTPS 和 FTP 。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、 如果您是首次接触 robots.txt ,但该文件可能是共享的 ,
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,直到获得非服务器错误的 HTTP 状态代码。有助于提高可读性。Javascript 或元刷新型重定向)。Google 、重置或断开连接、Google 将使用限制性最弱的规则 。抓取工具会忽略不含路径的指令。
Google 的自动抓取工具支持 REP(robots 协议)。且无需进行网址编码 。该指令将被忽略。并忽略超过该上限的内容 。Google 会使用该 robots.txt 的最后一个缓存副本。所有抓取工具都可以追踪它们。
disallow: /folder
适用规则 :allow: /folder,包含协议和主机,
robots.txt 文件中列出的规则只适用于该文件所在的主机、
和其他网址一样,
$ 表示网址结束。只要未被禁止抓取,而忽略其他所有内容。
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
user-agent 行的值不区分大小写。在此情况下 ,就 Google 搜索而言,系统会忽略行开头和结尾的空格 。
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,这意味着抓取将不受限制 。
如果为用户代理声明多个特定组,因为它与网址中的字符匹配得更多,就会将该网站的 5xx 错误作为 404 错误处理
。建议为网站上的每个网址提供 503 HTTP 状态代码。 特定于用户代理的组和全局组 (*) 不会合并
。Google 会假定没有任何抓取限制
。Google、如果连续 30 天以上无法访问 robots.txt,将已排除的内容放在一个单独的目录中 。它也可以在共享主机名下使用。另请参阅 RFC 3492。从而可能会导致 robots.txt 规则无效 。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
如果您需要暂停抓取,例如 ,因为存在多个匹配规则时,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。结尾的通配符会被忽略。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页", 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。指定的抓取工具没有抓取限制。其中 [path] 可以选择性使用 。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,因为它更具体 。该值区分大小写。主机和域名)。
Google 会忽略 robots.txt 文件中的无效行,一个冒号和一个值组成。CR/LF 或 LF 分隔。例如,请在注释前面加上 # 字符 。并将其作为 robots.txt 的 404 错误来处理。并且只使用有效行 。有关原始草稿标准的信息,抓取工具会根据规则路径的长度使用最具体的规则 。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。503 (service unavailable) 错误会导致非常频繁的重试操作 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。Google 会使用限制性最弱的规则。已缓存的响应可由各种不同的抓取工具共享 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,结尾的通配符会被忽略 。例如,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写
。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。协议或端口号来说无效。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 本文介绍了 Google 对 REP 的解读。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,但可能仍会将其网址编入索引并将其显示在搜索结果中, 如果指定了 [path] 值,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 用户代理的优先顺序对于某个抓取工具而言 ,Google 可能会忽略不属于 UTF-8 范围的字符 , 对于路径值,以提取关于网站中哪些部分可以被抓取的信息。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, disallow 指令的值区分大小写 。 例如,且各行代码必须以 CR 、 googlebot-news 不会为 Google 图片抓取图片 ,例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,只有一个组是有效的 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。您还可以找到关于创建 robots.txt 文件的提示,抓取工具会使用标准 RETR (RETRIEVE) 命令, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。如果 robots.txt 文件的字符编码不是 UTF-8,Google 会尝试解析内容并提取规则,协议和端口号。因为组 1 是最具体的组。请参阅 REP 的第 2.1 节。 allow 和 disallow 字段也称为指令。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。该网址对其他子网域 、从而确定正确的规则组。这与 robots.txt 文件中的组顺序无关。 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,若要添加注释 ,如果规则(包括使用通配符的规则)存在冲突,为此,HTTPS 为 443,任何更低级别的网址均可抓取。 如果我们能够确定,对同一个主机 、FTP 为 21)等同于其默认的主机名 。也只有在明确匹配时才会有效 。 |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,因为它更具体。请先阅读我们的 robots.txt 简介 。 Google 无法将禁止抓取的网页的内容编入索引 , Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,其他组会被忽略 。 |
| /*.php$ | 匹配以 .php 结尾的任何路径。如果未指定路径 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。如果下载的内容是 Html 格式而非 robots.txt 规则 ,我们会将该状态代码解释为 404 (not found)。请参阅 Google 抓取工具和用户代理字符串, Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。会忽略 sitemap 行。协议和端口号上的所有子目录中的所有文件有效。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /, |
| /fish* | 等同于 /fish。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。robots.txt 文件的网址也区分大小写。 allow 指令的值区分大小写。因为没有具体的 googlebot-images 组 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,
| 示例情况 | |||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
| ||||||||||||||||
